Technical requirements

What are the technical requirements for the Online Library? 

Click on the tabs below for more information about the technical requirements necessary to view the Online Library subscription resources.

we recommend All browsers  

All Online Library resources are supported by all internet browsers.

Mozilla Firefox (version 3 or higher) and Internet Explorer (version 7 or higher) and Google Chrome support all the resources.

If you are having problems viewing some of the resources, try using a different browser. Firefox and Chrome can resolve a lot of problems that may be experienced when access ebooks and EBSCOhost databases.